Glance setup

This page describes how to set up your development environment to use Glance.

Add Glance dependencies

Add the specific Glance dependency in your app's module based on the features you need:

dependencies {
   // For AppWidgets support
   implementation "androidx.glance:glance-appwidget:1.0.0"

   // For interop APIs with Material 2
   implementation "androidx.glance:glance-material:1.0.0"

   // For interop APIs with Material 3
   implementation "androidx.glance:glance-material3:1.0.0"

}

You can get the latest available version from the Glance release page.